HDU 1222(数论,最大公约数)

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
 

Input

The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 

Output

For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
 

Sample Input

2
1 2
2 2
 

Sample Output

NO
YES

程序分析:由上面的标题可以知道是求最最大公约数,但是一定不要超时,我有递归时间只用了0MS,其实这里我用了long long 型 ,其实没必要,int型也是可以的。还有我的if语句也是个出错点,就是因为这个答案一直不对。

程序代码:

#include<iostream>
#include<algorithm>
using namespace std;
#include<cstdio>
#define ll _int64
int gcd(int n,int m)
{
    
    return m==0?n:gcd(m,n%m);
    
}
int main()
{
    int T;
    ll n,m,k;
    cin>>T;
    while(T--)
    {
        scanf("%I64d%I64d",&n,&m);
        if(n<m)  
            swap(n,m);
        k=gcd(n,m);
        if(k==1)
            
            cout<<"NO"<<endl;
        
        else    
            
            cout<<"YES"<<endl;
        
        
    }
    return 0;
}
原文地址:https://www.cnblogs.com/yilihua/p/4740683.html