POJ2782:Bin Packing

Description

Download as PDF
 

A set of n<tex2html_verbatim_mark> 1-dimensional items have to be packed in identical bins. All bins have exactly the same length l<tex2html_verbatim_mark> and each item i<tex2html_verbatim_mark> has length li$ le$l<tex2html_verbatim_mark> . We look for a minimal number of bins q<tex2html_verbatim_mark> such that

  • each bin contains at most 2 items,
  • each item is packed in one of the q<tex2html_verbatim_mark> bins,
  • the sum of the lengths of the items packed in a bin does not exceed l<tex2html_verbatim_mark> .

You are requested, given the integer values n<tex2html_verbatim_mark> , l<tex2html_verbatim_mark> , l1<tex2html_verbatim_mark> , ..., ln<tex2html_verbatim_mark> , to compute the optimal number of bins q<tex2html_verbatim_mark> .

Input 

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.


The first line of the input file contains the number of items n<tex2html_verbatim_mark>(1$ le$n$ le$105)<tex2html_verbatim_mark> . The second line contains one integer that corresponds to the bin length l$ le$10000<tex2html_verbatim_mark> . We then have n<tex2html_verbatim_mark> lines containing one integer value that represents the length of the items.

Output 

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.


For each input file, your program has to write the minimal number of bins required to pack all items.

Sample Input 

1

10
80
70
15
30
35
10
80
20
35
10
30

Sample Output 

6


Note: The sample instance and an optimal solution is shown in the figure below. Items are numbered from 1 to 10 according to the input order.

epsfbox{p3503.eps}
 
将所有物品由大到小排序,从大到小装入物品,如果某个装了一个物品的BIN的余量可以再装入一个物品,就把物品转入,否则就申请一个新的BIN.
 
#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;
int x[100002];
int main(){
    int t;cin>>t;
    int g=1;
    while(t--){
        if(g++!=1)puts("");
        int n;cin>>n;int m;cin>>m;
        int sum=0;
        for(int i=0;i<n;i++){
            scanf("%d",x+i);
        }
        sort(x,x+n);
        int i=0,j=n-1;
        while(i<j){
            if(x[i]+x[j]<=m){
                j--;i++;sum++;
            }else{j--;sum++;}
        }
        if(i==j)sum++;
        cout<<sum<<endl;
    }
return 0;
}
View Code
原文地址:https://www.cnblogs.com/demodemo/p/4716079.html