自建nodejs服务器(一:有个服务器)

之前在阿里云备案过,也买过域名和虚拟主机(6元一年),可惜虚拟主机虽然说可选linux或windows系统,但linux系统只支持几个php程序,一番折腾,云栖社区的大伙们都说要弄node得买个ECS服务器,但基于价格考虑,还是买了海外的Vultr VPS。

1.购买VPS:

https://www.zhihu.com/question/20800554

Vultr购买攻略:http://vultr.jiaochengwang.top/

过程非常简单,阿里云支付一下就搞定了也不用备案。

2.有了自己的VPS后,简书上有两个很详细:

购买vps并使用XShell教程(文章很短,主要看XShell部分):

  http://www.jianshu.com/p/c182dc23fbba

安装node的教程:

  http://www.jianshu.com/p/0496ef49b2a5

  注意安装node教程里边有些细节问题:

  1.作者给的XShell 百度云已经无效了,但可以在百度软件下载:

  http://rj.baidu.com/soft/detail/15201.html

  2.步骤中,在加载并解压完node后,./configure这一步可能会报错说系统找不到解压器,

  solution: 安装gcc-c++ ,命令如下 : 

  yum install gcc-c++

  3.解压缩mongodb时,作者给出的命令中mongodb的版本不一致,再解压时把解压命令中的版本号改为加载的版本号即可。

  4.添加CentOS开机启动项这一步,可能会报错说vim: command not found.

  soluton:输入rpm -qa|grep vim 命令

                如果还是不行,就输入yum -y install vim*,然后再一次  rpm -qa|grep vim

  参考:http://linushai.blog.51cto.com/4976486/1154871

             http://helpdesk.blog.51cto.com/219783/591464

  5.对不不熟悉Linux或vim/vi使用的同学,可以花30s看看菜鸟这篇简单教程:http://www.runoob.com/linux/linux-vim.html

  6. 在Mongodb 2.4.x以上版本中,创建用户的命令是db.addUser而不是db.createUser,按照作者这里的创建用户命令会报错(当然版本方面我们自行选择)

      参考:https://stackoverflow.com/questions/23034841/typeerror-occurs-when-trying-to-enable-mongo-db-authentication

   7.git 命令无效

    solution:sudo yum install git

  8.git clone repo-address 出现Permission denied (publickey).

   参考githubhelp:https://help.github.com/articles/error-permission-denied-publickey/

    其实最直接的方案是在Linux上创建新的ssh key 并加到你的github agent上:

    Generating a new SSH key and adding it to the ssh-agent

    Adding a new SSH key to your GitHub account

    上面两个链接的介绍中,出现过apt-get 命令,如果你们用的是centOS系统,会出现apt-get: command not found,将apt-get: 改为yum即可。

    原因是基于redhat的系统安装的是yum而不是apt-get,centOS是基于redhat的发行版。

原文地址:https://www.cnblogs.com/alan2kat/p/7640566.html