1009. Product of Polynomials (25)

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6


double和int比较存在误差,需要同类型比较,难怪第一个测试点总是不对。

代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <queue>
using namespace std;
int main()
{
    int k1,k2,a,z[10];
    double num[10],an,ans[2002]={0};
    int c=0,maxi=0;
    scanf("%d",&k1);
    for(int i=0;i<k1;i++)
    {
        scanf("%d%lf",&z[i],&num[i]);
    }
    scanf("%d",&k2);
    for(int i=0;i<k2;i++)
    {
        scanf("%d%lf",&a,&an);
        for(int j=0;j<k1;j++)
        {
            int d=a+z[j];
            ans[d]+=num[j]*an;
            if(d>maxi)maxi=d;
        }
    }
    for(int i=0;i<=maxi;i++)
        if(ans[i]!=0.0)c++;
    cout<<c;
    while(c)
    {
        if(ans[maxi]!=0.0)
        {
            printf(" %d %.1f",maxi,ans[maxi]);
            c--;
        }
        maxi--;
    }
}
原文地址:https://www.cnblogs.com/8023spz/p/7295764.html