1006. Sign In and Sign Out (25)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133


根据时间判断。。把时间都变成秒来比较大小就好了。。

代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <queue>
using namespace std;

int main()
{
    int n;
    char ch;
    int sh,sm,ss;
    int eh,em,es;
    string name;
    string minn,maxn;
    int mint=24*3600,maxt=0,s,e;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>name>>sh>>ch>>sm>>ch>>ss>>eh>>ch>>em>>ch>>es;
        s=sh*3600+sm*60+ss;
        e=eh*3600+em*60+es;
        if(s<mint)mint=s,minn=name;
        if(e>maxt)maxt=e,maxn=name;
    }
    cout<<minn<<' '<<maxn;
}
原文地址:https://www.cnblogs.com/8023spz/p/7290719.html